【再】IImage browser(日本語版)

前回、日本語化したのだが、追記に次ぐ追記で本人も訳わからなくなりつつあるので、再びまとめる。加えてその使用方法なんぞをフクちゃんのために書いておきたいと思う。

なんで、今更そんなことを言うかというと「文字化け」フォルダーがフォトディレクトリー内で発見されたため。たぶん、IImage browserで誤ってディレクトリーを作成したと思われ・・・。まぁ、Adminエリアをゴチャゴチャ弄くり、後のフォローをしてない私が悪いんですけどね・・・。

■インストール編
1)iimage-browser-plugin.phpsとiimage-browser.phpsを入手する。
iimage-browser.phpsは、Taste of Wind『IImage browserを改造する』で日本語版と英語版が紹介されています。

【追記】
iimage-browser.phps [ver 1.4.5-Beta](日本語版)を編集しました。
IImage-browser 日本語版 にまとめてあります。

2)テキストeditor等でphpとして保存し、
iimage-browser-plugin.phpはwp-content/pluginsへ、
iimage-browser.phpはwp-adminへアップロードする。

3)wp-admin/edit-form-advanced.phpの93行目の
<?php the_quicktags(); ?>の下に
<?php do_action(‘edit_form_advanced_buttons’, ”); ?>を書き込む。

4)プラグインを有効化する。

5)投稿画面のテキストエリアの上あたりに「画像を挿入する」のリンクがあれば、成功です。

【注意】
WP-ContactFormのv1.1を入れているとボタンを押下してもウィンドウが開かないようです。v1.2にバージョンアップすると解決できます。

■使用方法
1)「画像を挿入する」リンクをクリック。

2)右上の「アップロード」をクリック。

IImage Browser1

3)「参照」をクリックし画像を選択後、「アップロードする」をクリック。

IImage Browser2

4)選択した画像が表示されるので、画像をクリックする。

IImage Browser3

5)画像の下に各種選択画面が現れる。
今の場合は画像が640×480で大きすぎるので、一番下のサムネイル化をしてみます。

IImage Browser4

6)長辺側の大きさを任意に設定し、コピー生成か元画像と置き換えるかを選択し、「サムネイル化する」をクリック。

IImage Browser5

7)また、画像をクリックすると、画像の下に各種選択画面が現れる。

8)表示方法を選択し、「コード生成」をクリックするとテキストエリアのタグが表示される。すると「投稿欄に貼付」がクリックできるようになるので、クリックすると投稿エリアの文字の最後にタグが貼り付けられる。

IImage Browser6

これで終了かな。

でも、基本的に画像の名前は絶対に半角英数字(出来れば小文字)ですからぁ∼っ!!
(ファイル名がバケると削除できないのよ :cry:

※現在v1.4.3Betaになってますが、あまり変更はないので気にしてません。あしからず。

スポンサーリンク
  • このエントリーをはてなブックマークに追加

コメント

  1. centree より:

    こんにちは。
    wp1.5.1preをインストールしてIImage browser(日本語版)プラグインを入れてみました。
    絶対パスにてiimage-browser.phpを指定すると動いてくれるのですが、投稿画面に、「画像を挿入する」が表示されません。
    …情報が少ないのですが、何か原因が考えられますか?

  2. centree より:

    追記:

    そういえば、iimage-browser.phpを起動した画面の上に、こんなものが出てきます。
    Warning: Cannot modify header information – headers already sent by (output started at **************************/wp/wp-admin/iimage-browser.php:1) in **************************/wp/wp-admin/admin.php on line 6

    Warning: Cannot modify header information – headers already sent by (output started at **************************/wp/wp-admin/iimage-browser.php:1) in **************************/wp/wp-admin/admin.php on line 7

    Warning: Cannot modify header information – headers already sent by (output started at **************************/wp/wp-admin/iimage-browser.php:1) in **************************/wp/wp-admin/admin.php on line 8

    Warning: Cannot modify header information – headers already sent by (output started at **************************/wp/wp-admin/iimage-browser.php:1) in **************************/wp/wp-admin/admin.php on line 9

    (*****部分は、伏せさせていただきました)

  3. Masayan より:

    はじめまして、centreeさん。

    ココはまだME 1.5.1-preにバージョンを上げてないんでなんとも
    言えませんが、今週中にはME 1.5.1-preにする予定ですので、
    しばらくお待ちを・・・。 :arrow-d:

  4. centree より:

    すみません。はじめてWPを入れたので、右も左も分からず、ファイルとにらめっこしてました。MTに比べ情報が少ない(当たり前ですが)ので、Masayanさんのようなblogにすがるしかありません。
    急ぎませんので、また分かりましたらよろしくお願いしますm(_ _)m

  5. Masayan より:

    ME 1.5.1-prにしました。で、問題のIImageは・・・
    私の環境ではエラーを吐きませんでした。

    上のインストール編の3)は当然OKでしょうが、もう1度確認して
    みてください。centreeさんのエンコードにあわせて、テキスト
    エディータで保存してるかもあわせてご確認を・・・。

    何を初歩的な・・とお思いでしょうが、案外小さなミスがエラーを
    引き起こすことは多いものです。(体験談・・汗)

  6. centree より:

    やはり治りません…。きちんとUTF-8で保存しなおして
    みましたが、だめでした。何が原因なんだろう??

    しかし、元ファイル(英語バージョン)の
    iimage-browser1.4.4は正常に動きました☆
    とりあえずはこちらを使ってみようと思います。

    そういえば、1.4.4はedit-form-advanced.phpを書き換える必要がありませんでした。その辺が関係しているのかな…。また研究してみます。フォーラム見ていますのでまた何か便利なプラグインがあったらよろしくお願いします☆

  7. Masayan より:

    お役に立てなくて申し訳ない。 :oops:

    1.4.4のボタンの生成はいいですねぇ、クイックタグ内で。
    これに替えよっと。

    ちなみに62行目を

    edit_insert_button(“画像を挿入”, “iimagebrowser”, “IImage Browser”);

    とすれば、日本語化。 :lol:

  8. Castaway。 より:

    ようやく1.4.5導入しました。
    現在のところ、エラーは出ていないようです。
    訳に手を入れてみましたので、目を通していただけると幸いです。
    http://bless.babyblue.jp/wp/files/iimage-browser_1.4.5J.phps
    何かあればまたご連絡下さい。訂正後アップしたいと思います。

    >centreeさん
    iimage-browser.phpのみ日本語版でも使えますので、試してみてはどうでしょう?

  9. Masayan より:

    なるほど。訳がわかりやすい。orz
    完成ですね。 :cool:

    https://wp.mmrt-jp.net/files/plugin/iimage-browser_1.4.5J-kai.phps

    私はこう改造して使ってます。機能縮小版です。 :arrow-d:

  10. uma より:

    はじめまして、こんにちは。
    通りすがりのものです。

    centreeさんのエラーが出る件、私の環境でも再現しました。
    私の場合は、iimage-*.phpの最終行に空白の行がありましたので、
    それを削除したら正常に動くようになりました。

    すでに解決済みかもしれませんが、報告まで・・・。

  11. tagigo より:

    はじめまして。
    最近、worldpress1.5を導入しまして試行錯誤してやっています。
    とても便利そうなので、ぜひIImage browserを
    使ってみたいと思っているのですが、どうもうまく動いてくれません。
    2つのファイルを指定の場所に置いてアクティベイトさせても、
    投稿の画面上に何の変化も起きてくれません。

    どうやらプラグインそれ自体が機能していないようなのです。
    (もともと入ってたプラグインも何も変化がありませんし)
    何か、基本的なことを見落としているのではないか、と思うのですが、
    どっぷりドツボにはまってしまい、見当がつきません。
    ご教示いただければ幸いです。

  12. Masayan より:

    はじめまして、tagigoさん。
    1つもプラグインが働かないということなのでしょうか?

    1)MEの場合、プラグイン画面の右端のアクションが「無効化」になっているか?

    2)プラグインディレクトリーのパーミッションは777(書き込み可能)になっているか?

    3)自サイト/wp-admin/iimage-browser.phpを直接叩いてみる。
    (表示するなら、投稿画面のどこかにリンクを埋めれば、最悪使えますが・・・)

    パッと思いつくのはコレくらいです。 :oops:
    またご報告ください。
    すごい助っ人も知っているので頼んでみますよ?!

  13. tagigo より:

    Masayan さん、レス有難うございます!

    アドバイスいただいたとおり、確認してみましたところ、

    >1)MEの場合、プラグイン画面の右端のアクションが「無効化」になっ>ているか?

    こちらは、確かにアクティベイトされてまして、プラグイン名が太字になっていました。

    >2)プラグインディレクトリーのパーミッションは777(書き込み可能)>になっているか?

    これは、やってませんでした!
    これだったか∼、と喜び勇んで、変更してみたのですが、これでも画面に変更なしでした。。。
    でも勉強になりました。有難うございました。

    状況についてですが、
    xreaで運用しています。
    サブドメインで運営していこうとおもって
    public_html下のsub_domainフォルダにworldpressをコピーしてインストールしました。

    これがまずかったかな、とメインドメインで試してみようと、public_html直下に展開させてみましたが、特に変わりはありませんでした。
    文字コードはEUC、UTF8両方とも試してみました。

    デフォルトで装備されているアップローダーは使用できています。

    プラグインが自由に使えれば、本当に可能性が格段に広がりますよね。
    なんとか使いこなしたいものです。

    なにせ、ライブドアブログからの移行なので、かなり基礎的な事がわかっていないところがあると思います。
    また何か、お気づきの点がありましたら、お願い致します。

  14. Masayan より:

    今見ると、かなり的外れな答えですな>オレ。orz

    iimage-browserのバージョンは何でしょうか?

    xreaってサーバーによって、かなり差があると聞いています。
    プラグイン全滅だとすると大元が原因だったりして・・・。 :idea:

  15. tagigo より:

    Masayan さん ご返答有難うございます。

    >xreaってサーバーによって、かなり差があると聞いています。

    えっ、そうなんですか!
    今、worldpressを導入しているのは
    s149.xrea.comサーバーです。
    サーバーのバージョンを調べたところ、こんな感じででてきました。

    CPU : AMD Athlon(tm) 64 Processor 3500+
    MemTotal : 2056220 kB
    Apache : 1.3.33
    Perl : v5.8.3 built for x86_64-linux-thread-multi
    PHP : 4.3.11
    RUBY : 1.8.1 (2003-12-25) [x86_64-linux]
    MySQL : 4.0.23, for unknown-linux on x86_64
    PostgreSQL : 7.4.6

    >iimage-browserのバージョンは何でしょうか?

    1.4.2と1.4.5を試してみました。

    上記のような状態でやっているのですが、どうでしょうか?
    お手すきの時にでも、診断していただければ有難いです。

  16. Masayan より:

    tagigoさん、hiromasa zone 掲示板で特別講義中です。是非、ご参加ください。 :arrow-d:

  17. hiromasa より:

    はじめまして。お待ちしております。 :arrow-d:
    うちのサーバ遅いので、繋がらなかったら時間おいてどうぞ・・・。

  18. tagigo より:

    Masayan さん、hiromasa さん、どうも有難うございます。
    教えていただいたサイトですが、今の時間帯は混雑しているようですので、時間をずらして、ぜひ訪問させていただきます!

  19. tagigo より:

    Masayanさん、こんばんは。

    iimage-browser
    今日、動いてくれました!
    ひろまさ師匠の、毎日の問診のおかげです。

    ご紹介して下さいまして、本当に有難うございました!
    また、ちょくちょく訪問させていただきます。

    P.S.Masayanさんは、バイク乗られてるんですね。
    僕も前、モンスター400に乗っていたのですが、
    ちょっと経済的な問題により今は、マジェスティに乗っています。
    でも皆とツーリング行くとストレス溜まるんですよね!
    そろそろ禁断症状がでてきたので、近々復帰したいと思ってます。

  20. Masayan より:

    よかったですね。
    hiromasa zoneを覗いていたのですが、割り込む頭脳もなく・・・。 :arrow:

    しかし、結構バイク乗りの方は多いですな。
    お金や体力に関わらず楽しみましょう、バイクライフを! :arrow-d:

  21. […] 投稿に簡単に画像を挿入できるIImage Browserを入れていましたが、バージョンを更新することにしました。今までのは日本語化がされた時に入れてから更新していなかったので。 やり方はWPのフォーラムを参考にしてみましたが、どうもうまいこと更新されていない。なんでかなぁ?って思っていたら、古い方のファイル名と新しい方のファイル名が少し違っていて、アドミンパネルのプラグインページに別々に表記されていて、古い方は有効化されていましたが、新しい方はされていませんでした。すぐに古い方を削除して新しい方を有効化しました。 今までは”Insert Image”というリンクが1番上の右端の方にリンク付ででていて、そこをクリックしたらポップアップ画面が出てきていたのですが、今回は投稿を入力するすぐ上のクイックタグにIImage Browserと表示されます。クリックしてみたらどうしてもポップアップ画面が出てきません。色々と試行錯誤してみるものの、何もきかず・・・。そうしたらMMRT daily lifeさんの【再】IImage browser(日本語版)という記事に注意書きで WP-ContactFormのv1.1を入れているとボタンを押下してもウィンドウが開かないようです。v1.2にバージョンアップすると解決できます。 […]

コメントをどうぞ

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

:x :wink: :twisted: :shock: :sad: :oops: :o :mrgreen: :lol: :idea: :evil: :cry: :cheesy: :arrow-u: :arrow-l: :arrow-d: :D :?: :) :!: 8)