WP-PageNavi2.70にしてみたら・・・

何の気なしに管理画面のプラグインページからWP-PageNaviをアップグレードしてローカライズチェックしてみると・・・

ダメゼッタイ?!

あれれれっ?

ボク、最高権限者なんですけど?

おかしい、こんなはずでは。いろいろとググってもそのような事例はないらしい。また、ボクだけなの?(苦笑)

よーーく、観察してみる。ぴこん! これか?

なんだかなー

こんなバカな仕様ってアリですか? 前のバージョンでは、

$base_name = plugin_basename('wp-pagenavi/pagenavi-options.php');
$base_page = 'admin.php?page='.$base_name;
$mode = trim(@$_GET['mode']);
$pagenavi_settings = array('pagenavi_options');

こんな箇所がありましたけど、2.70はないっすねぇ。

AdminPage.phpの304行目付近だと思うんだけど、素人さんはこれ以上わからず・・・。orz まぁ、「PageNavi」を訳さなければ問題ないですけどね。 :cry:

スポンサーリンク
  • このエントリーをはてなブックマークに追加

コメント

  1. ゆりこ より:

    WP-PageNavi を捨てましょう;-) 正直なところ、左右の端という一番目立つところに「First」「Last」という「あまり使わないもの」を並べているのは、ユーザーインターフェースとして好ましくありません。ここは本来は「前のページ」「次のページ」が来るべきです。
    アクセスログをきちんと確認しなければなりませんが、おそらく、意図せず「First」や「Last」に行ってしまっている人がいると思います。

    ということで「WP-PageNavi を使わずにナビゲーション表示 (改良版)」がおすすめです。

    • Masayan より:

      もちろん、ゆりこさんの記事は知っていますし、しようとしたこともありました。
      が、あまりにトラブルが減るとネタも減るわけで・・・。 :lol:

      記事ネタとリハビリのためにそんなプラグインたちを使い続けているというのが実情だったり・・・。 :cheesy:

コメントをどうぞ

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

:x :wink: :twisted: :shock: :sad: :oops: :o :mrgreen: :lol: :idea: :evil: :cry: :cheesy: :arrow-u: :arrow-l: :arrow-d: :D :?: :) :!: 8)