Ubuntu15.04のデフォルトGW消失事件

7月の更新は異常。w

先日7日の火曜日の夜。わりと大きなアップデートがあったようで更新したら、再起動。長いこと起動するのにかかりまして・・・。で、Firefox立ち上げて調べ物をしていると・・・

サーバが見つかりませんでした

はぁ? まだ立ち上げて1分くらいしか立ってませんぜ。実は15.04にアップグレードしてからちょいちょい接続が切れることがあったので、ネットワークマネージャーから切断→接続とすると復旧したりしておりました。当然その流れでそうしてみましたが・・・

つながらん!

今回はどうも何をしても繋がらないようでした。それでも調べるとネットワークには繋がっている模様。LAN内のNASのファイルは見れるのです。外部につながらないだけ? しかし、そんなに暇でもなかったので放置して翌日、ツイッターにぼやいたら突っ込んでくれる御仁がいました。そうです。(確信犯ともいうw

デフォルトゲートウェイとして設定されるIPアドレス(ルーター)の設定が消えた感じの動きですねー。お時間あるときでも ifconfig コマンドで default gateway のところ見てみてください!

無線LANのドライバーだとかいろいろ見当違いなことを考えていましたが、彼が言うのですから間違いありません。帰ってから確認しましょう。

で、確認するとやはりというか、FMV機はデフォルトゲートウェイを消失していました。とにかく調べなくてはいけませんが、スマホでは拉致があかないので呪文を唱える。

sudo route add default gw 192.168.xx.xx

これであっさり復旧。FFを閉じても立ち上げてもつながっています。直った? ラップトップを閉じてサスペンドさせてから確認すると既にデフォルトGWを消失。パソコンのくせに頭わるいのぅ。ww

サスペンド後呪文を唱えればそれまでなのですが、そんな面倒なこと嫌でしょ?

調べると /etc/network/interfaces に up route add default gw 192.168.xx.xx を加えればいいとありましたので実践。試行しますがダメです。忘れてます。www

それからは、バグだって情報からサスペンドじゃなくてハイバネートだ!って情報からinterfacesで固定IPだってことまでやりましたが効果なし。

ふて寝しようと風呂に入って一案出ました。

interfacesは無視して、ネットワークマネージャーで設定したら?

と思いつきました。だって、interfacesの情報を変えても反映されていないんですもの。

で、interfacesには・・・

auto lo
iface lo inet loopback

これだけ。

あとはネットワークマネージャーで固定IP情報を設定するとうまくいきました。何度ラップトップを閉じても立ち上がります。よかったよかった。

いつものようにひろまさに感謝しながら、眠りにつきましたとさ。北には足を向けられんなぁ。(頭も向けられませんが・・・w

スポンサーリンク
  • このエントリーをはてなブックマークに追加

コメントをどうぞ

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

:x :wink: :twisted: :shock: :sad: :oops: :o :mrgreen: :lol: :idea: :evil: :cry: :cheesy: :arrow-u: :arrow-l: :arrow-d: :D :?: :) :!: 8)